Forenbeitrag (mehr als 15 Kommentare)

ABS Kontrollleuchte leuchtet nicht

Bild von heiner1

Hallo zusammen!

ich komme gerade vom TÜV, der mir die Abnahme verweigerte, da die ABS Kontrollleuchte nicht leuchtet. D.h. beim Einschalten der Zündung sollte sie für 3 Sekunden leuchten und dann wieder ausgehen, um zu zeigen, dass das System durchgeprüft und einsatzbereit ist. Bei mir leuchtet sie leider überhaupt nicht.

Das Kombiinstrument habe ich eben schnell ausgebaut und auseinandergenommen, da ich eine defekte Birne vermutet habe. Aber es sind jedoch festgelötete LEDs verbaut, bei denen ich stark zweifele, dass dies einfach so kaputt gehen, oder was meint ihr?.

Fehlerdiagnose via VCDS lite ergab nichts. Kein Fehler, alles in Ordnung. Beim Durchprüfen des Kombiinstruments via VCDS lite ist mir dann noch aufgefallen, dass auch die Leuchte für das Wischwasser nicht funktioniert. Vielleicht hängt das irgendwie zusammen?

Im Motorraum hinter der Batterie habe ich einen Blick auf das ABS Steuergerät geworfen (soweit das möglich ist, ohne sich mit Alltagskleidung komplett in den Motorraum zu werfen) und auf Anhieb mal nichts Auffälliges wie defekte Kabelisolierungen oder sonstwas festgestellt.

Jemand eine Idee wo der Fehler liegen könnte? Vielleicht doch einfach mal die LED herauslöten und ersetzen? Weiß jemand welche Spannungen diese LEDs brauchen/vertragen? 3.3V oder 5V vielleicht, wie das bei Mikroelektronik üblich ist? Ich habe natürlich auch kurz den Multimeter an die LED des ABS drangehalten und geschaut was es anzeigt. In die eine Richtung wie zu erwarten nichts (ist schließlich eine Diode) und in die andere Richtung ganz kurz Durchlass. Keine Ahnung ob das so normal ist, eigentlich müsste die Diode erst ab einer gewissen Schwellspannung durchschalten und ich weiß nicht ob diese mit einem Multimeter ohne weiteres zu erreichen ist und so ernst zu nehmende Ergebnisse zu messen sind...

Re: ABS Kontrollleuchte leuchtet nicht

Bild von James75
1

Hallo Heiner

eine ganz blöde Frage, die ich allerdings in deinem Text nicht lesen.
Funktioniert das ABS eigentlich und nur die Lampe nicht oder geht das ABS System auch nicht?

gruss
Roman

Re: ABS Kontrollleuchte leuchtet nicht

Bild von Tornador

ABS testen und Rückmeldung geben

Re: ABS Kontrollleuchte leuchtet nicht

Bild von heiner1

Ja sorry, vergessen dazuzuschreiben. Das ABS regelt wie gewohnt. Vollbremsung aus 50 km/h und alles stottert, kein Reifenquietschen, eben alles wie es soll.

Re: ABS Kontrollleuchte leuchtet nicht

Bild von heiner1

Hab gerade nochmal gemessen was beim Kombiinstrument ankommt. Zwischen Masse und Pin 19, der für das Plus der ABS Leuchte zuständig ist, messe ich 1,5 Volt beim Start. Weiß jemand ob die 1,5 Volt reichen bzw. ob die LEDs mit 1,5 Volt bestromt werden?

Die LED rauszulöten und zu ersetzen ist für mich in 2 Minuten erledigt, ich müsste nur wissen auf welche Spannung sie auslegt sein muss, wirklich nur 1,5 Volt?

Belegung der Pins habe ich hier gefunden: https://avdi-forum.de/avdi_aktuell/index...

Re: ABS Kontrollleuchte leuchtet nicht

Bild von Tornador

Es gab doch hier im Forum schon mehr als einmal solche Fälle, wuren glaube ich per Forendoc mit löten instandgesetzt

Re: ABS Kontrollleuchte leuchtet nicht

Bild von Dr. Cache

Wie war das noch Think

@Meschi, kannst Du mir auf die Sprünge helfen?

Edit: Habe es gefunden.
[432375]
https://www.sgaf.de/content/hilfe-doc-ca...
[432429#39]

Leider hatten wir keine Fotos gemacht, aber es war glaube ich eine Leiterbahn auf der Platine gebrochen, das hatten wir auch nur durch Zufall gemerkt als wir auf die Platine gedrückt haben und die Lampe daraufhin kurz leuchtete.

Re: ABS Kontrollleuchte leuchtet nicht

Bild von heiner1
1

#6

Sehr gut zu wissen, ich hab den Tacho schon ausgebaut hier liegen und werde mich später dran machen. Klingt für mich nach dem Durchmessen auch absolut am plausibelsten, gerade noch in Verbindung mit der nicht funktionierenden Wischwasserleuchte. Danke für die Hinweise! Und wenn ich was zum knipsen finde, werde ich es auch für die Nachwelt festhalten Prima

Re: ABS Kontrollleuchte leuchtet nicht

Bild von Meschi

@Dr. Cache

Ja, ich meine, dass es so war. Ein Wackelkontakt bzw. irgendwo eine Mini-Unterbrechung auf der Platine. Wir haben diese Unterbrechung gesucht, aber letztlich nicht gefunden. Kann irgendwo ein Haarriss gewesen sein. Wer weiß.
Draht drübergebraten und fertig......

Gruß
Meschi

Re: ABS Kontrollleuchte leuchtet nicht

Bild von Heisenberg

Bei mir war bei dem "neuen" gebrauchten KI eine LED von der Blinkeranzeige defekt.
Ich habe 2 andere grüne LEDs besorgt und auf beiden Seiten eine LED durch eine neue ersetzt. Auf die Art habe ich keine unterschiedliche Farbe. Ich würde im Zweifelsfall eine neue LED besorgen und die LED tauschen.

Re: ABS Kontrollleuchte leuchtet nicht

Bild von stopfohr
1

heiner1 in #4 schrieb:

Die LED rauszulöten und zu ersetzen ist für mich in 2 Minuten erledigt, ich müsste nur wissen auf welche Spannung sie auslegt sein muss, wirklich nur 1,5 Volt?

LEDs haben in dem Sinne keine Betriebsspannung. Für die ist nur der Strom, der durchfließt, wichtig.
Mach’s wie Heisenberg, besorg dir eine passende Standard-LED, und bau die ein.

Oliver

Re: ABS Kontrollleuchte leuchtet nicht

Bild von heiner1

#10

Stimmt so nicht 100 prozentig. Die LED wird idR mit Konstantstrom betrieben und kann dabei per PWM gedimmt werden, nicht wie bei Glühbirnen über die Spannung. Trotzdem ist sie auf eine gewisse Spannung ausgelegt und kann natürlich auch kaputt gehen bzw. gar nicht erst angehen, wenn diese nicht eingehalten wird.

Aber abgesehen davon:
Ich habe am Samstag einfach an den entsprechenden Pin des Steckers auf der Platine ein Kabel + 1000 ohm Widerstand gelötet und dieses dann an den Pluspol der LED geführt. LED ohne Widerstand beitreiben würde diese nämlich nach sehr kurzer Zeit grillen. Danach hat die LED aber dauerhaft geleuchtet, obwohl erstens kein Fehler vorliegt und zweitens auch am Stecker messbar ist dass nur am Anfang kurz Spannung an den Pin geführt wird. Sehr mysteriös...

Wenn ich die Leiterbahnen verfolge und nachmesse sehe ich auch, dass ich sowohl von LED-Seite als auch von Steckerseite aus schnell an Transistoren stoße. Offensicht also eine etwas komplexere Schaltung. An welcher Stelle habt ihr das Kabel denn eingelötet?

Re: ABS Kontrollleuchte leuchtet nicht

Bild von Heisenberg

Einfach die bestehende LED 1:1 ersetzen.
Das ist alles...
Ich habe ohne Kabel eine SMD LED eingelötet. Man muss natürlich die Polung beachten.

Re: ABS Kontrollleuchte leuchtet nicht

Bild von heiner1
2

#12

Danke für den Hinweis, hab ich bereits probiert und hat nicht gebracht.

Aaaaaaaaber: Das Problem ist gelöst! Ich habe nochmal alles nachgemessen und strukturiert nachvollzogen.

1. Am Stecker kommt für die Zeit in der die LED leuchten soll eine positive Spannung an
2. Die LED im Instrument ist mit Dauerplus verbunden und wird auf Masse geschaltet
-> Es bringt nichts einfach den Pin am Stecker mit dem Pluspol der LED zu verbinden Laughing #

Ich habe das Problem mit Hilfe einer kleinen Transistorschaltung gelöst bekommen Idea

1. Basis des Transistors an den Pin 19, an dem das ABS Steuergerät die Spannung anlegt anlöten

2. Emitter des Transistors an Masse löten

3. Kollektor des Transistors über einen 1k Ohm Widerstand mit dem zu schaltenden Minuspol der LED verbinden. Ich habe das einfach gleich am Flachbandkabel gemacht, da hier sicher noch die Verbindung zur LED messbar ist.

Wichtig zu beachten bei der Schaltung: NPN Transistor verwenden, der bestenfalls eine recht niedrige Schwellenspannung zum Durchschalten benötigt. Ausserdem unbedingt alles sauber isolieren um Kurzschlüsse und im Endeffekt teure Probleme und Schäden mit der Boardelektronik zu vermeiden. Ich habe dick Panzertape verwendet, optimal wäre natürlich Isolierband. Zum Schluss auch alles gut fixieren, damit keine Lötstellen brechen oder kalt werden. Wer es gaaaanz besonders perfekt machen will kann zudem noch von der Basis des Transistors auf Masse einen hohen Widerstand einlöten (z.B. 10k Ohm), der dafür sorgt dass die Elektronen an der Basis auch wieder abwandern.

Im Anhang die versprochenen Bilder zur Problemlösung.
Danke nochmal an alle für eure Hilfe, wenn ich auch mal helfen kann lasst es mich wissen  

Transistorschaltung für defekte LED im Tacho 1Transistorschaltung für defekte LED im Tacho 2Transistorschaltung für defekte LED im Tacho 3

 

Re: ABS Kontrollleuchte leuchtet nicht

Bild von hinki

#13 Sehr schön gemacht. Prima Dann ist der TÜV ja jetzt ein Klacks.

Re: ABS Kontrollleuchte leuchtet nicht

Bild von stopfohr
1

heiner1 in #11 schrieb:

Stimmt so nicht 100 prozentig

Doch, tut es (abgesehen von Hocspannungsdurchschlägen und ähnlichen Effekten in kV-Bereich). Das erkennt man ja schon daran, daß man LEDs gar nicht nach Spannung kaufen kann. Ist aber egal, die LED in deinem KI funktioniert ja noch.

Oliver

Re: ABS Kontrollleuchte leuchtet nicht

Bild von Heisenberg

Richtig!
Hast Du diagnostiziert warum die Schaltung im KI nicht funktioniert?

Re: ABS Kontrollleuchte leuchtet nicht

Bild von stopfohr

Hier gibt es was zum Vor-Facelift-KI

[253286]

Vielleicht ist das Nach-Facelift ja ähnlich aufgebaut.

Oliver

Re: ABS Kontrollleuchte leuchtet nicht

Bild von heiner1
2

#16

Ich habe von beiden Seiten her Stück für Stück durchgeprüft bis ich die Leiterbahnen nicht mehr nachvollziehen konnte. Das ganze verliert sich recht schnell in einem wirrwarr aus Widerständen und Transistoren (nehm ich an bei den SMD Packages) und ist dann nicht mehr nachvollziehbar. Örtlich passiert das rund 4 cm nach unten und 5 cm nach rechts vom angelöteten Flachband aus.

Komme übrigens gerade erfolgreich und mängelfrei vom TÜV der erst meinte, dass ich was geknaupt hätte damit die Leuchte irgendwie brennt und mich dann begeistert ausgefragt hat, als ich ihm die gleichen Bilder wie euch hier gezeigt und erklärt habe Very Happy

Re: ABS Kontrollleuchte leuchtet nicht

Bild von heiner1
1

#15

Ich denke wir haben beide recht Think Very Happy

Natürlich ist eine LED in erster Linie auf den Strom und nicht auf die Spannung ausgelegt, ist ja auch nur eine Diode. Trotzdem verträgt sie nur bestimmte Spannungsbereiche da schlicht der Übergang zwischen den p und n Schichten zu heiß wird und verbruzzelt, wie auch bei nicht lichtemittierenden Dioden. Kilovoltbereiche benötigt es hierzu aber nicht, das passiert schon deutlich früher. Power LEDs werden idR auch mit maximal 34 V betrieben.

Die Strommenge wird ansonsten über Spannung+Widerstand begrenzt, eben um Konstantstrom zu erzeugen wie du sagst.

Wie auch immer, hier gehts weniger um LED-Technik sondern drum die LEDs im Tacho zum Leben zu erwecken Prima

Re: ABS Kontrollleuchte leuchtet nicht

Bild von stopfohr

Vermutlich reden wir fröhlich aneinander vorbei. Das geht schon damit los, was man unter einer LED versteht.

Macht aber nix. Leuchtet trotzdem Wink

Oliver

Re: ABS Kontrollleuchte leuchtet nicht

Bild von heiner1
3

Noch ein Nachtrag:

Mir ist eben noch aufgefallen, dass die ABS LED leicht glimmt, sobald die Lichtmaschine läuft. Also hab ich munter mit Basiswiderständen rumprobiert um das Problem mit dem NPN Transistor irgendwie unter Kontrolle zu bekommen. Hat leider in allen Variationen nichts gebracht, er hat immernoch leicht durchgeschaltet und die LED hat leicht geleuchtet. Auch andere Widerstände an der LED haben nichts gebracht.

Daher hab ich einfach nen MOSFET (IRLZ24N) mit 2kOhm Widerstand vor dem Gate eingelötet und jetzt läuft alles einwandfrei, ohne glimmen oder sonstwas Groehl

Für potentielle Nachbastler nochmal im Detail:
- Pin 19 des Steckers an 2.000 Ohm Widerstand
- Von dem Widerstand dann an Gate des IRLZ24N
- Drain direkt an Masse (Pin 1 des Steckers = Masse)
- Source an 1.000 Ohm Widerstand
- Von dem 1.000 Ohm Widerstand irgendwo an die zu steuernde LED, ich habs am Flachbandkabel drangelötet

Ausserdem habe ich noch die Verbindung ab dem Flachbandkabel auf der Platine mit einem scharfen Messer rausgekratzt, nicht dass da am Ende nur ein Wackler vorliegt und sporadisch doch irgendeine Verbindung hergestellt wird, die im dümmsten Fall nochmal zu einem Ausfall führen kann Cool

Inhalt abgleichen Mobile Version
Customize This
sharan